我要投搞

标签云

收藏小站

爱尚经典语录、名言、句子、散文、日志、唯美图片

当前位置:高清跑狗图 > 读整数内存 >

关于易语言的读内存与写内存的代码问题

归档日期:06-26       文本归类:读整数内存      文章编辑:爱尚语录

  具体要实现以下:搜索某个进程的从09000160到09FFF170内存地址里的所有文本,把搜索到的这段内存地址内的字符串“pppp1234”改成“vvvv5678”。具体代码如何?用易语言编写~3个回答都...

  具体要实现以下:搜索某个进程的从09000160到09FFF170内存地址里的所有文本,把搜索到的这段内存地址内的字符串“pppp1234”改成“vvvv5678”。具体代码如何?

  可否帮我直接把代码写出来?别给例子,直接把代码写上,代入上面给出的数据.............展开我来答

  可选中1个或多个下面的关键词,搜索相关资料。也可直接点“搜索资料”搜索整个问题。

  哇,你说用什么程序写?你要说清楚啊。是用C 还是C++ 还是C# 还是其他什么语言?

  .子程序 创建进程, 逻辑型, 公开, 从文件创建进程,成功后可直接进行本类其它操作,本类原操作句柄会自动释放

  .子程序 创建内存, 整数型, 公开, 在目标进程中创建内存空间(成功返回内存指针地址,失败返回0)

  .子程序 打开窗口进程, 逻辑型, 公开, 通过窗口对象来打开进程,成功后可直接进行本类其它操作,本类原操作句柄会自动释放

  .子程序 打开进程, 逻辑型, 公开, 通过进程ID来打开进程,成功后可直接进行本类其它操作,本类原操作句柄会自动释放

  .子程序 读取, 字节集, 公开, 读取内存中数据(返回字节集,失败返回空字节集)

  .参数 长度, 整数型, 可空, 读取的长度,读取文本型可留空,字节型1,短整数型2,整数型4,长整数型8

  .子程序 读文本, 文本型, 公开, 从内存中读取文本(返回文本,失败返回空“”)

  .子程序 读整数, 整数型, 公开, 从内存中读取整数型数据,失败返回-1

  .子程序 关闭进程, 逻辑型, 公开, 创建进程或打开进程后,不再需要进行内存等操作时,关闭进程,该命令会在本类销毁时自动被调用

  .子程序 是否有效地址, 逻辑型, 公开, 判断进程中指定内存地址的有效性!(成功返回真,失败返回假)

  .子程序 搜索, 整数型, 公开, 进行内存搜索(返回结果数目,失败或没有返回0)

  .参数 搜索内容, 字节集, , 欲搜索的内容 其他类型-需自行转换为字节集类型

  .参数 回调进度, 子程序指针, 可空, 回调进度(进度值%) 如果有返回值返回真则停止搜索

  .子程序 线程注入, 逻辑型, 公开, 通过创建远程线程方式注入DLL到指定进程中(成功返回真,失败返回假)

  .子程序 写文本, 逻辑型, 公开, 往内存中写入文本(成功返回真,失败返回假)

  .子程序 写整数, 逻辑型, 公开, 往内存中写入整数(成功返回真,失败返回假)

  .子程序 再次搜索, 整数型, 公开, 在已经搜索过的情况下进行再一次搜索(返回结果数目,失败或没有返回0)

  .参数 搜索内容, 字节集, , 欲搜索的内容 其他类型-需自行转换为字节集类型

  .参数 回调进度, 子程序指针, 可空, 回调进度(进度值%) 如果有返回值返回真则停止搜索

  .子程序 置已有进程, , 公开, 设置一个已经打开的进程,然后可直接进行本类其它操作,本类原操作句柄会自动释放

本文链接:http://sarlnogues.com/duzhengshunacun/459.html